
MILLING GUIDE
By Megan Bates

How to turn your arduino project into a beautiful, robust little shield. Ideal for exhibition 
pieces, projects you want to remove from your arduino without complete dissasembly, mass 
production modular pieces, or circuitry artworks.

NOTE: The shield shown here is not what I will be demonstrating in this guide, though it would 
be very easy to adapt. This project can be found here: https://www.arduino.cc/en/Tutorial/
ArduinoToBreadboard



STEP 1: CREATING YOUR CIRCUITRY DESIGN IN EAGLE

Download Eagle for free here: https://www.autodesk.com/products/eagle/free-download

On opening Eagle, create a new schematic:

From here, the unusual part of eagle is using the text based controls. There is also a graphical 
control scheme, but some tools need to be accessed via the text control.

add: introduce a new type of schematic component into the Eagle schematic.
net: draw wires to connect your components
delete: remove components and wires
move: relocate components and wires
etc. They are fairly self explanatory and many of these have graphical equivalents in the 
toolbar.



You need a library for Eagle to include the footprint information for Arduino. You can find 
an amazing collection of libraries for hobby electronics here: https://github.com/sparkfun/
SparkFun-Eagle-Libraries but the only one which is completely necessary is the Sparkfun-
Boards library.
You should be able to install your new library by opening the ADD window (by typing add 
into the schematic textbar), then opening the Eagle library manager. You can browse your 
computaer for the correct library using the ‘available’ tab and then clicking browse...

You will know your new library has been added when you can search in the ADD window for 
arduino, and the sparkfun arduino footprints appear. You will also want to include an LED 
footprint, for which sparkfun also has a good library.



Your schematic window now may look something like this. You now have all the components 
you need to make a working schematic. I actually recommend using the 3mm LED footprint for 
almost any component you might want to add, as it will ensure your design is more consistent 
later. You can label components with the ‘name’ tool rather than including different kinds of 
components, and it streamlines things as you can just copy-paste an LED when you need to 
extend your schematic rather than navigating the ADD menu again. 
As an example, I am going to build in the following image a working schematic for an Arduino-
controlled relay. The arduino will be able to control a power supply for a component which is 
much higher than the power supplied by the arduino. In the book, they use it to control a motor, 
but you could equally use a relay to control any high-power component, such as flickering 
a lamp on and off, controlling an electric lock on a door, or forcing a hard reset on another 
arduino project, to name a few ideas.



If you check this image against project 09: Motorized Pinwheel in the arduino book, you will 
see that this schematic is very nearly identical to the diagram they show. Creating a schematic 
can be very easy if you learn how to copy and adapt an example, so although this looks 
complex you don’t need to be intimidated! 
(You can find the project with schematic here if you don’t have the arduino book) http://astenor.
free.fr/Arduino/Projet_09/Project_09-EN-v2.pdf

You may have noticed I have a component other than an LED in my scematic- I used this 
sparkfun diode footprint as shown above.
You are now ready to organise your board (based on your schematic). You can navigate here by 
pressing the switch to board button in Eagle.



Your board window will now look something like this. You can arrange your components in 
the black area to allocate positions to your components. They will all be precisely scaled to fit 
perfectly onto your arduino once it is printed.

You now want to navigate to the design rules window. 
Here, in the clearance tab, adjust all spacings as follows 
(if you write mm the units will adjust automatically) 

Then, in the distance tab, adjust settings as follows:

It is possible that later you may need to adjust these 
values for Eagle to be able to route your circuitry. Eagle 
will show you an image of what it means when you 
mouse over these text boxes, see if you can get a grasp 
of what they mean.



Roughly arrange your components, try to get the yellow lines arranged in a fashion which is 
reasonably uncomplicated to improve your chances of getting a good circuit design. You now 
want to open the autorouter window from Tools>Autorouter. If you set ‘auto’ for preferred 
direction, and ‘high’ for effort, you will get the maximum amount of computational effort for 
complex boards and be likely to get a 100% routing. Unless you want to create a double-sided 
circuit board (you probably don’t!) Set the ‘bottom’ preferred direction to N/A. If you change 
any settings, make sure to uncheck the ‘continue existing job’ tickbox.

Under the sizes tab, apply these values.



It is quite possible that on running the 
autorouter you will get outcomes which 
aren’t 100% completed. If this happens, 
you can try adjusting the design rules 
(though just remember closer wires 
increase the chances of problems on 
the mill), rearranging components, 
or increasing the size of clearance 
of the black board area around your 
components. Don’t forget, if you change 
any settings, make sure to uncheck 
the ‘continue existing job’ tickbox on 
rerunning the autorouter.

You can evaluate to see which 
connections haven’t been made, and 
move components around to increase 
your chances of a good autoroute. If 
you do this, you then need to remove 
the routes before trying again. select 
everything with cmd+A, pick the ‘ripup’ 
tool, right click on a trace and select 
‘Group:Ripup’ > ‘Trace, via, or polygon’



Having rearranged the components a little, I pick the autorouter solution which I think looks 
best. I now need to export the design. To do this, I go to the View > Layer Settings window. I 
then turn off all layers using the ‘hide layers’ button, and switch on only the ‘top’ and ‘pads’ 
layers. I now export my board design using ‘File’ > ‘Print’. I make sure the settings are ‘print 
to file’ and ‘actual sclaing 1.00’. We are now ready to move onto tweaking our design in 
photoshop! 



STEP 2: TWEAKING YOUR CIRCUITRY DESIGN IN 
PHOTOSHOP

Open your exported PDF into Photoshop (or GIMP etc). Check as you import, the resolution 
should be 800 pixels per inch. I recommend cropping your circuitboard to have a little bit of 
breathing room around the design.

Your goal at this point is to produce 3 png images, examples of which I will show on the next 
page. I recommend setting colours to pure black and pure white, which you can streamline by 
using Image > Adjustments > Black & White. I also recommend using a 30 pixel wide pencil tool 
for drawing holes as it will make your life easier later.
 If you want, you can use this point as an opprtunity to stylise the board, adding design work or 
making the pathing smoother if you like. My examples will be straightforward.



Image 1: draw a 30pixel wide (ideally using 
an unaliased pencil) dot over each center of 
a pad, where we will drill a hole to push our 
components into the board

Image 2: The traces from Eagle, with holes 
in the centre of pads filled in. Make sure this 
image is pure black and pure white with a 
continguous paintbucket. It is worth scanning 
for any stray pixels while you are working on 
this- even small areas of the wrong colour can 
show up in the trace design later.
If you want to easily invert your image to be 
white on black, use Image > Adjustments > 
Invert.

Image 3: The outline of your board. This can 
be a fun shape if you like, but I have used a 
straightforward square.

Make sure to save each of these files onto a 
memory stick as a png file.

You are now ready to move on to building our 
milling files in fabmodules.



STEP 3: CREATING YOUR MILLING FILES IN FABMODULES

I recommend bringing your png files onto the Roland Mill computer via a memory stick at this 
point, and building your milling files on the hatchlabs mac. Open a web browser and navigate 
to fabmodules.org within the virtual machine.
If you are having problems accessing your memory stick files from within the virtual machine, 
try ejecting it from within the mac operating system and then accessing the USB within 
Windows. You will need to connect to the Roland Mill as well once you turn it on.
Now is a good time to check your scaling. There are callipers in the hatchlab. Check that the 
dimensions from fabmodules match the size you want your PCB to be.

If you copy the settings as shown here, you should have no problems milling a design which is 
constructed as described in the rest of this guide. That said, there are some settings to pay extra 
attention to.
Generally: Make sure the file type is .rml. The ‘process’ will depend on the image, check that 
selection is correct. always ensure zjog and zhome are more than 0, or the drillbit will crash 
into the surface. Don’t mess with the ‘send command’ or ‘server’ boxes from how they are 
autofilled. You shouldn’t need to adjust any boxes after the ‘offset overlap (%)’ one.
Holes image: Make sure both the stock thickness and stock depth are a little greater than the 
thickness of your board. Make sure the tool diameter is 0.86, I found this worked with 30pixel 
wide circles.
Trace image: You may want to increase the ‘cut depth’ value if the mill is not scoring well. Feel 
free to experiment with the number of offsets to change the look and speed of how your board 
is cut. You can preview this pressing the ‘calculate’ button.
Outline image: Keep your cut depth and speed very low, this is the stage which will break 
drillbits. 





I really recommend always pressing the ‘calculate’ button before saving the files, especially for 
drilling holes and drawing traces, so you can check the file is processing properly. Keep an eye 
out for strange features you weren’t expecting- sometimes a stray miscoloured pixel can break 
things. You can try adjusting the ‘image threshold’ value if you run into problems.

On pressing calculate, when you zoom in on 
your holes file, it should look like this. Not 
drawing a circle, but with arrow vectors in 
extremely localised points. If you see a circle 
appear, adjust the ’tool diameter’ to increase 
until the calculation is drawing nothing, and 
then reduce the value again util you get a result 
similar to this one. Tracing a circle will break 
the drillbit, so finding the right value is worth 
your time.

On pressing calculate, when you zoom in on 
your trace file, it should look like this, a good 
number of vectors drawn around each trace, 
and a generous amount of room for both traces 
and pads. 
It is quite possible that like in this example, 
you will have pads which are connected. This 
is preferable to having the machine remove 
too much material, but you will need to adjust 
the board once it is printed and use a knife or 
file to remove the small amount of material 
connecting the pads in order for your board 
to work properly. If, like with this example, the 
component you are attaching isn’t a specific 
one, you can manually adjust the positions of 
the pads in photoshop to allow for more room 
and have the mill clear the pads properly.
 I would recommend this if you wanted to mass 
produce a board, but usually I would remove 
areas like this by hand, since it is a good idea 
to go over the traces with a file after milling 
anyway.
We are now ready to move onto milling proper!



STEP 4: USING THE ROLAND MILL

APPROACHING PROCESSING YOUR PCB
I recommend for your first time:
		  1) testing hole drilling 
		  2) testing trace cutting
		  3) testing board outline cutting
		  4) drilling holes
		  5) drawing traces
		  6) cutting the board outline
		  7) Hand filing away stray bits of metal
This will require changing drill bits many times, but it is a good idea to cut the board after 
drawing traces so it will be well attached when it’s drawing traces. Drilling holes is the fastest 
stage of cutting, so I recommend doing this first to check if your design is the right size etc. 
before you spend ages waiting for traces to be cut.

BEFORE YOU START CUTTING
Check that the bed is level. Firmly attach the PCB board to the bed with double sided sticky 
tape. It should not move no matter how hard you try to remove it with your fingers. Make sure 
there are no obstacles the machinery could collide with. Use the mini Dyson hoover to clear out 
the inside.

An example of the kind of material you want to use for milling: https://uk.rs-online.com/web/p/
plain-copper-ink-resist-boards/2192117/
make sure the size is big enough for your project!

NOTES ON EACH STAGE OF MILLING:

Holes: Use a thin drillbit- eg. 0.8mm. This stage will be pretty quick, and will show you any 
glaring mistakes (eg. your design being too big for your board) straight away, which is helpful. 
Check you are drilling all the way through before you move your board!

Traces: Use a V-shaped carving bit. Pause your trace cut early to check the cut is deep enough. 
You should be cutting through the copper, but not getting rough edges on your cut. If the cut is 
too shallow, feel free to re-zero the z position slightly lower than before (you can do this off the 
edge of the copperboard) or adjust the cut depth in fabmodules.

Outline: Use a thin drillbit- eg. 0.8mm. This is where your drillbit will break! If you have time, 
run this as slow and shallow as you can. If you need to go faster, cut the first couple of outlines 
and then speed things up once you have a rut cut for the drill to trace in.



ZEROING THE MILLING MACHINE

Open the VPanel program in the virtual machine.

Choose User Coordinate system from the dropdown box.

Zeroing: bring the tip as close as possible using continuous, then x100, then x10 cursor step if 
at all close to the board. Undo screw until it drops (on the UPPER alan key screw hole), tighten 
it again. Tell VPanel that the tip is zeroed. Don’t try to calibrate by eye. Zero the Z axis only, you 
will get more consistent zero-positions this way. Don’t zero X-Y because the machine will lose 
track of where your board is between drill changes.

If you have just loaded a sheet to mill, DO zero X-Y, at the closest-left corner of the sheet. If you 
are starting a new board on a sheet which has already been cut, find the bottom-left corner of 
a clear area. measure to see if your board will fit against the fabmodules sizing dimensions.

VPANEL
Press ‘view’ to look at your work. Wait until its stopped moving to open the mill door. You can 
resume your trace- the mill will remember the X and Y locations, so it can continue where it left 
off.
Press CUT to load up your .rml file. 

! DELETE EVERYTHING ELSE IN THE LIST EVERY TIME YOU LOAD UP A NEW FILE. THE MILL 
WILL QUEUE OTHER THINGS IN THE LIST BEFORE YOUR WORK AND CUT THE WRONG FILE !

When you press Output the mill will start cutting. Keep an eye on what its doing and press 
CANCEL if the machine is cutting the wrong file, or something else is going wrong.

Projects I have completed using the Roland Mill-

If you have any further questions, feel free to contact me at meganlaurabates@gmail.com.




